Category Archives: Nerd Stuff

Samsung TV Doesn’t See DLNA Media Servers

Last night I tried to watch something from my media server on a TV that had no problem doing this before.

The media server is a DLNA server running on a Synology NAS.

It took a bit of searching before I found the solution so I’m recapping it here to help anyone else with the same problem.

The key here was that I changed my router a little while ago. The new one is an Asus mesh system.

This is where I found the solution:

The Asus app to manage the routers is fantastic, but this setting isn’t available in it. You need to access the web interface.

Go to the LAN section, then to the IPTV tab, and change the setting for “Enable multicast routing” to Enable.

As soon as I changed the setting the media server showed up in the Sources options on the TV, just as it had always done before.

The Virtual Machine That Crashes Hyper-V on AMD

Last weekend I upgraded my server. It was supposed to be easy. I talked about the network adapter problems here:

It was 4 am Sunday morning when that problem got solved. I thought it would be smooth sailing from there.

Now connected to the network, I imported my VM’s and started up my webserver. Everything was peachy. My websites were back online and the system was stable.

I started up my file server. I started up my Windows 10 VM, which was slow as molasses before the upgrade and was happy to find it working well.

I started up a Windows 7 VM, just to start pushing the new hardware a bit. Then this happened:

When it happened, the whole system froze and had to be hard-rebooted with the power switch.

That little display is supposed to make troubleshooting easy. You look up the code and it tells you what the problem is. Unless it’s an 8.

If it’s an 8, you start Googling it and find a bunch of different things that MIGHT be causing it but nothing conclusive.

The first one I found said it was insufficient CPU power.

Normally I wouldn’t think there was a power issue. It’s got a 650 watt power supply. Thing is, the power supply doesn’t have a 4-pin ATX CPU power connector. I found an old Molex to ATX adapter and then couldn’t find the pack of modular wires for the PSU.

I found one that fit but there wasn’t any branding on it to say if it was meant for the current PSU. I used it anyway and figured it would be fine.

When the error came up, that became the primary suspect. I wasn’t sure about either the PSU cable or about how power is supplied. Knowing that two wires were being used to feed 4, I thought maybe I’d made a mistake there.

I used a multimeter to make sure that the PSU cable was correct and I was getting 12 volts instead of 5 or something else. That was fine. I still wasn’t sure if there might be a reason the ATX connector uses 2 wires instead of just one for12 volts. Maybe the PSU limits the amps on that channel or something. I have no idea.

I looked into buying a new power supply. I was gutted to see how expensive they are. I expected around $80 for a good one but they’re double that now.

I did surgery instead. I chucked out the cable with the Molex connectors and took apart the adapter and one of the PCIe 6-pin connectors that wasn’t being used. After some cutting and taping and poking at the connectors with bent staples I ended up with a 4-pin ATX connector that was definitely getting enough power.

It didn’t work. Well… it DID work, but it didn’t solve the problem. The system would still boot up and then crash within a minute with the code 8.

More searching made the situation sound more and more dire. It seemed like something was broken.

Bad CPU? Bad motherboard? Bad memory?

Maybe just some bad BIOS settings?

I updated the BIOS to the latest version, which also wipes out any custom settings. Rebooted. Same error.

More bad memory?

I swapped the memory between the server and my desktop. Same error.

It was now around 6 or 7 am. This was supposed to be easy.

I didn’t want to do this anymore. I wanted to sleep. I remembered that it was working when it was only running my web server. I thought of ways to get back to that.

I started it up and manically kept refreshing the Hyper-V manager on my workstation until it responded and then immediately killed all the VM’s except the webserver.

It worked. It didn’t crash. I went to bed.

When I woke up later on Sunday, I thought about what might cause the problem and how I could narrow it down.

I started the rest of the VM’s. It crashed.

I turned them off using the same method from earlier; frantically refreshing the manager until it responded and then killing them. With just the webserver and fileserver running, it was stable.

What caused it? Too much memory usage? Too much CPU demand?

I changed the settings on the Windows 10 VM to give it all of the available memory on startup. It started. It ran fine. I opened up 5 different YouTube videos and played them all simultaneously. I could see the CPU usage going up.

It ran fine.

I started up the Windows 7 VM again. It crashed almost immediately. It makes no sense to me. How does a VM crash the hardware?

I did more experiments and everything pointed to the VM being the issue. Nothing else I tried caused a problem. The system was running well unless I started that one VM. Then it crashed within seconds.

I deleted the VM and created a new one using the existing virtual hard drive. It started up and worked fine. I let it run like that for days. It was flawless.

Yesterday I re-imported the original VM and started it up. It crashed.

With this new knowledge, I did more searching and found I’m not the first one to have this happen. There’s a detailed story here about someone in a similar situation, migrating a VM from an Intel based server to an AMD one and then having random crashes:

So there you have it. I’ve got a VM that can crash my server’s hardware and throw a code on the motherboard. I have no idea how that’s possible, but it is.

Hopefully this will help someone else with this very specific problem in the future. The solution for me was to create a new VM using the existing VHD.

Installing Network Drivers on Hyper-V with Intel I211-AT Network Adapter

This is nerd stuff. Stop reading and wait for my next post if that’s not immediately interesting to you.

I’m writing this as a how-to for anyone else that has this problem. I know I’m not the first, but I might be the first to get it resolved.

For reference, I’m installing Hyper-V Server 2019 on an Asus ROG Crosshair VII Hero (WiFi) motherboard with an AMD Ryzen 2700x processor.

This past weekend was an adventure. I’ve been running a web server for decades now. It’s a personal playground for me to mess around with new technologies when I find the time. It’s always run on nearly obsolete hardware. Whenever I upgrade my desktop, the scraps go to the server.

In the past few weeks, I’ve been trying to use a Windows 10 VM on it and it’s been slow as molasses. When I ran the PC Health Check app to see if I could upgrade it to Windows 11, it didn’t even offer suggestions. It just did this:

So for the first time ever, I decided to upgrade my desktop while it’s still sort of current and finally give my server some modern guts.

It was supposed to be simple. Swap the parts in, install a fresh copy of Hyper-V server, fire up my VM’s, and call it done. An hour. Maybe two, tops.

I wasn’t expecting the built-in network card to be unsupported and not be able to connect to the network. Connecting to the network is important for it. That was a problem.

The first thing I looked for was how to install a device driver. I found this, which was very helpful:

After that, I went looking for the driver to install and found I had a bigger problem. There wasn’t one available.
Figuring out what to do next, I came across this guy from a few years back with the same problem:

He didn’t seem to resolve it, but pointed me to this guy, who got Intel drivers working for a different unsupported network adapter:

It took a bit of trial and error but I got the gist what he’d done enough to adapt it to my system.

I downloaded the Intel drivers from here:

Note that the I211-AT isn’t on the list there.

Going back to the first link, there’s a utility that lets you see devices similar to what the Device Manager shows on a regular Windows installation. You can get it here:

Using that, I found my ethernet adapter listed and could see what the system saw it as. It was this:

The important bit is the Device Instance ID.

I searched through the pile of stuff in the Intel driver package and found an entry very similar in e1r65x64.inf in the [Intel.NTamd64.10.0.1] section.

%E1539NC.DeviceDesc% = E1539.10.0.1, PCI\VEN_8086&DEV_1539

Looking at what the guy with the NUC did, I added a line below it to match what mine showed up as:

%E1539NC.DeviceDesc% = E1539.10.0.1, PCI\VEN_8086&DEV_1539&SUBSYS_85F01043

I then copied both lines down to the next section as suggested. So at the bottom of the list for [Intel.NTamd64.10.0] I added these:

%E1539NC.DeviceDesc% = E1539.10.0.1, PCI\VEN_8086&DEV_1539
%E1539NC.DeviceDesc% = E1539.10.0.1, PCI\VEN_8086&DEV_1539&SUBSYS_85F01043

Here’s what it looks like. Note that I kept the 10.0.1 bit in the middle. On my first attempt I thought I was clever and removed it to match the rest of the lines in this section. It didn’t work.

Then I followed the rest of the instructions as follows:

I copied the whole NSID65 folder, with my modified inf file, to the server and ran the following commands:

bcdedit /set TESTSIGNING ON
bcdedit /set nointegritychecks ON

Then I rebooted the server.

shutdown /r /t 0

When it came back up, I installed the driver using this command:

pnputil –i –a C:\NDIS65\e1r65x64.inf

You’ll get a warning about it being potentially tampered with. Well… yeah. I just tampered with it.

Choose to install it anyway.

Hopefully it will be successful this time. It was for me.
Now run these commands to turn the driver enforcement back on.

bcdedit /set TESTSIGNING OFF
bcdedit /set nointegritychecks OFF

Now reboot again, and it should be good to go!

Drop a comment if this helped you. I hope at least someone is saved a lot of frustration with this.

Corel Can Eat a Bag of Dicks

There’s a lot going on right now with my personal nerd projects and part of it involves retiring the web and file server that’s been serving me well for what feels like forever now. It’s been a good run, Windows Server 2008!

As I’m getting ready to shut it down, I’m taking some time to go through all my old files and clear out stuff I’ll never need again.

In that ancient stuff I found some old CorelDRAW files I made back in the mid to late 90’s. The oldest is dated October 4th, 1995.

It stands to reason that none of the software I have today would open them. The kicker here though is that apparently even COREL software won’t read them anymore and it seems like they’ve made a business model out of dropping support for older file formats on a regular basis.

If you use CorelDRAW, apparently you have to open and resave all the files you want to keep or you’ll never be able to open them again. Way to punish your long time users, Corel!!

Anyhow, in a thread on the CorelDRAW community forums that started “over 15 years ago” and has a latest post from “over 2 years ago” I found a little tidbit that I hope to pass on to others in the same predicament.

There’s a site called cloudconvert and they are able to convert the ancient .cdr files to .svg format and did a fine job of it.

You can find the converter here:

Finally, here’s a rainbow I drew for some reason in 1996.

Turn Off Windows 7 Guest Media Sharing

For as long as I’ve been using my Windows 7 computer to share media for watching on my TV through the PS3, I’ve been annoyed at the fact that the computer’s Guest account has it’s own set of folders and shows up as a separate media server on the network. There’s nothing in it. It’s just annoying.

So here’s how to stop it.

1. Stop the Windows Media Player Network Sharing Service

2. You need admin access for this step to get access to the folder. Delete the folder “Media Player” in c:\users\guest\appdata\local\microsoft

3. Restart the Windows Media Player Network Sharing Service (or just reboot).

Done. Gone.

I Installed Windows 8 And It’s Annoying

Last night I installed the Windows 8 Consumer Preview in a virtual machine so I could play around with the new interface and see what all the hubbub is about.

My initial reactions really aren’t positive. With the new Metro interface, I really got the impression that it probably works well on a tablet, but it’s a big hindrance on a workstation. Everything jumps to full screen mode. There’s no obvious way to close programs. Solitaire doesn’t work in a remote desktop session. How the hell do you break Solitaire??

The interface seems to randomly jump back to the old style now and then, depending on what program you run, but it’s still missing any sort of traditional start menu to run other programs.

I found that there was a general lack of tool tips on icons so I had no idea what they did, and right-clicking stuff never seemed to do anything of value. I guess you can’t right-click with your finger on a touchscreen, so they just didn’t bother with it.

Overall, I’m really quite disappointed. I understand the convergence of operating systems between phones and tablets. Apple did it, and Google did it, and it makes sense.

Converging the desktop interface just doesn’t make any sense at all though. I mean… why do I need to keep hitting the Windows key to get out of programs? Why can’t I just click on the other window to go do something there… besides the fact that there seems to be no other windows.

I know this is just a preview and there could be major changes coming. I HOPE there are major changes coming. Otherwise I suppose it’ll be Windows 7 for the next generation for me. Why not? I’m still running Windows XP at work.